Określenie liczby mieszczącej się w zakresie

Użytkowanie arkusza kalkulacyjnego

Określenie liczby mieszczącej się w zakresie

Postprzez Inferno882 » Śr sie 08, 2018 12:14 pm

Witam,
może ktoś mi pomoże przy wyborze funkcji. Mam dane w danej komórce, które dzielę stale przez 80. Wynik powstały z tego dzielenia chcę dopasować do zakresu. Np.: jeżeli wynik dzielenia jest pomiędzy 5-10 to 12, jeżeli pomiędzy 10-20 to 15. Próbowałem to wykonać funkcją JEŻELI, ale pojawia się błąd, którego nie mogę skorygować:
=JEŻELI(G27/80<=0,5;13,5;JEŻELI(1>=G27/80>0,5;15,5);JEŻELI(2>=G27/80>1;17);JEŻELI(5>=G27/80>2;19))

Z góry dziękuję za pomoc
Open Office 2.4 pod Ubuntu 18.04
Inferno882
 
Posty: 2
Dołączył(a): Śr sie 08, 2018 12:08 pm

Re: Określenie liczby mieszczącej się w zakresie

Postprzez Jermor » Śr sie 08, 2018 3:58 pm

Użyj funkcji WYSZUKAJ.PIONOWO albo WYSZUKAJ.POZIOMO. np w taki sposób:
Kod: Zaznacz cały   Rozszerz widokZwiń widok
=WYSZUKAJ.PIONOWO(A1/80;{0;0|5;12|10;15};2)

przy założeniu, że liczba podstawowa jest w A1. Funkcję możesz odpowiednio rozbudować.
Zapis w nawiasach { } w tej funkcji to tak zwana stała tablicowa tutaj odpowiadająca dwukolumnowej tablicy o trzech wierszach.
Jeśli chodzi o twoje funkcje JEŻELI to całkiem słabo się do nich zabrałeś.
Poczytaj o nich np tutaj:
https://yestok.pl/ooo/y57.php
AOO 4.1.5, LO 6.0.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają taki sam problem, będą wiedzieli, że jest rozwiązanie.
Jermor
 
Posty: 452
Dołączył(a): So paź 12, 2013 11:09 am

Re: Określenie liczby mieszczącej się w zakresie

Postprzez Inferno882 » Cz sie 09, 2018 5:06 pm

Dziękuję Jermor za pomoc. Poczytałem trochę na temat funkcji JEŻELI i próbowałem Twojej sugestii, ale bez skutku. Chyba do końca nie o to mi chodziło. Postaram się przedstawić jeszcze raz na przykładzie.

Mam do obliczenia kwotę za wysyłkę paczki. Kwota jest uzależniona od jej wagi. Mam tylko wpłaty i informację, że za kilogram paczki trzeba zapłacić stałą kwotę 80 zł. Teraz potrzebuję funkcji, która podzieli kwotę wpłaty np.: 190 zł przez 80 zł. Ok wyjdzie około 2,375. Teraz ta wartość musi zostać przypisana do przedziału cenowego dotyczącego opłaty za ilość kilogramów. I tak np.: jak paczka mieści się w przedziale 0-0,5 kg płacimy 13, jak w przedziale 1-2 kg to 15 zł itd.

To co chcę osiągnąć to funkcja która policzy mi od razu kwotę jaką muszę zapłacić za przesyłkę, czy będzie to 13 zł, czy 15 zł etc. Próbowałem zrobić to funkcją JEŻELI, tak jak zauważyłeś nieudolnie :| , lecz nie chce mi tego policzyć w ten sposób. Jestem laikiem w kwestii funkcji dlatego próbuje różnych sposobów. Na mój gust przedziały/zakresy, które ustawiam nie są zamknięte, w sensie, że tylko od 1 do 2 i się nakładają stąd błąd. Być może się mylę.
Open Office 2.4 pod Ubuntu 18.04
Inferno882
 
Posty: 2
Dołączył(a): Śr sie 08, 2018 12:08 pm

Re: Określenie liczby mieszczącej się w zakresie

Postprzez Jermor » Cz sie 09, 2018 6:59 pm

To właśnie wylicza podana przeze mnie funkcja WYSZUKAJ.PIONOWO. Problemem jest tabela opłat. Z tego co napisałeś nie jest ona spójna. Napisałeś bowiem, że od 0 do 0,5 kg cena wynosi 12 zł a od 1 do 2 15. A co z wagą od 0,5 do 1?
W załączeniu masz przykład wykorzystania tej funkcji.
Załączniki
paczki.ods
(9.51 KiB) Pobrane 1 raz
AOO 4.1.5, LO 6.0.6 (x64) na Windows 10 64bit
Ważne!
Jeśli twój problem został rozwiązany, wróć do swojego pierwszego postu, przejdź do edycji i dopisz [SOLVED] w temacie.
Inni, którzy mają taki sam problem, będą wiedzieli, że jest rozwiązanie.
Jermor
 
Posty: 452
Dołączył(a): So paź 12, 2013 11:09 am


Powrót do Calc

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości