Pannello di Controllo Moderatore ]

Somma valori condizionato

Discussioni sull'applicazione per i fogli di calcolo

Somma valori condizionato

Messaggioda SKAL » sabato 11 agosto 2018, 13:41

Salve a tutti,
ho creato un elenco con in una colonna ho dei valori che vengono scelti da un elenco (dati-validita'-elenco) e a fianco ho la quantita' di ogni valore inserito

Ora vorrei fare in un altra pagina la somma dei valori per ogni occorrenza del mio elenco.

bianco 1
rosso 1
blu 2
verde 3
bianco 4


bianco 5
rosso 1
blu 2
verde 3

Come facci a fare la formula per il secondo elenco?

spero di essere stato chiamo.

grazie

LM
OpenOffice 3.1 su Windows Vista
SKAL
 
Messaggi: 1
Iscritto il: sabato 11 agosto 2018, 13:32

Re: Somma valori condizionato

Messaggioda gioh66 » sabato 11 agosto 2018, 15:53

Buondì, visto che non hai allegato un file, l'ho creato io mettendo i colori nell'intervallo A2:A25 e i valori nell'intervallo B2:B25 del Foglio1 e supponendo che ti serva anche, nel Foglio2, l'elenco dei colori univoci.
Per ottenerlo, in una colonna del Foglio1 che si potrà nascondere metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=CONFRONTA(A2;$A$2:$A$25;0)

e tiri in basso.
Poi nel Foglio2 per i colori univoci, in A2 metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(VAL.ERRORE(INDICE(Foglio1!$A$2:$A$25;PICCOLO(SE(FREQUENZA(Foglio1!$D$2:$D$25;RIF.RIGA(Foglio1!$D$2:$D$25)-1);RIF.RIGA(Foglio1!$D$2:$D$25)-1);RIF.RIGA($A1))));"";INDICE(Foglio1!$A$2:$A$25;PICCOLO(SE(FREQUENZA(Foglio1!$D$2:$D$25;RIF.RIGA(Foglio1!$D$2:$D$25)-1);RIF.RIGA(Foglio1!$D$2:$D$25)-1);RIF.RIGA($A1))))

Formula matriciale da attivare con i tasti ctrl+maiuscolo+invio e da ricopiare in basso.
Nella colonna B2 invece, per la somma dei valori corrispondenti, metti
Codice: Seleziona tutto   Espandi visualeStringi visuale
=SE(A2="";"";SOMMA.SE(Foglio1!$A$2:$A$25;A2;Foglio1!$B$2:$B$25))

e tiri in basso.
Ti allego file di prova
Allegati
somma valori per colore.ods
(9.68 KiB) Mai scaricato
Libreoffice 6 / Ubuntu 18.04 - PcLinuxOS
Libreoffice 5.1 / Ubuntu 16.04 - LinuxMint 18
Avatar utente
gioh66
Volontario
Volontario
 
Messaggi: 445
Iscritto il: lunedì 31 luglio 2017, 14:57


Torna a Calc

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti