Utiliser plusieurs conditions?

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

Utiliser plusieurs conditions?

Messagepar GM41 » 13 Sep 2017 14:00

Bonjour à tous :)

Je viens tout juste de m'inscrire pour une question plutôt urgente mais toute bête pour vous je pense...

Dans le fichier je crée une cellule avec menu déroulant, admettons les valeurs "1" - "2" - "3"

En colonne A2, je souhaite qu'automatiquement le tableau m'indique des valeurs suivant A1.

Exemple:
- si A1=1, alors A2 affichera "A"
- si A1=2, alors A2 affichera "B"
- si A1=3, alors A2 affichera "C"

Il ne s'agit pas de plusieurs conditions mais du coup je trouve pas ma solution... d'habitude je trouve sur youtube ou ici mais là je me suis inscrit pour vous exposer le problème...

Merci à ceux qui liront et encore plus à celui ou celle qui pourra me répondre :super:
OpenOffice 5.1.6.2 sous Ubuntu
GM41
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 13 Sep 2017 13:45

Re: Utiliser plusieurs conditions?

Messagepar tintin » 13 Sep 2017 14:15

Bonjour,

Il y a probablement mieux car je ne suis pas expert mais voilà une réponse
Code : Tout sélectionner   AgrandirRéduire
=SI(A1=1;"A";SI(A1=2;"B";SI(A1=3;"C")))

GM41.ods
(8.99 Kio) Téléchargé 3 fois
AOO 4.1.3 / MacOS X 10.13.1 High Sierra / RAM 8Go / Time Machine
Java 1.8.0_152/ Firefox / Safari / Thunderbird
Tutoriels du forum pour MacOS
Pensez à sauvegarder régulièrement votre travail avec l'
extension de sauvegarde incrémentale
Avatar de l’utilisateur
tintin
ManitOOu
ManitOOu
 
Message(s) : 4627
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Utiliser plusieurs conditions?

Messagepar Jeff » 13 Sep 2017 14:24

Bonjour,

Pour les chiffres de 1 à 26, en A2 :
Code : Tout sélectionner   AgrandirRéduire
=CAR(A1+64)


A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.4 sur Xubuntu 16.04 et sur Win 10 pro x64
Avatar de l’utilisateur
Jeff
GourOOu
GourOOu
 
Message(s) : 7127
Inscrit le : 18 Sep 2006 10:40
Localisation : Hautes-Alpes, France

Re: Utiliser plusieurs conditions?

Messagepar GM41 » 13 Sep 2017 14:41

Jeff a écrit:Bonjour,

Pour les chiffres de 1 à 26, en A2 :
Code : Tout sélectionner   AgrandirRéduire
=CAR(A1+64)


A +


bonjour

pas compris :/

tintin a écrit:Bonjour,

Il y a probablement mieux car je ne suis pas expert mais voilà une réponse
Code : Tout sélectionner   AgrandirRéduire
=SI(A1=1;"A";SI(A1=2;"B";SI(A1=3;"C")))

GM41.ods


c'est ce que j'utilise mais à priori le problème vient de la case valeur "source" ... en gros je ne peux pas mettre n'importe quoi comme valeur et il faudrait absolument que ce soit des chiffres? si j'ai une valeur comme "Bidule 01" par exemple, ça ne fonctionnerait pas ...? donc impossible pour moi d'utiliser cette fonction :(
OpenOffice 5.1.6.2 sous Ubuntu
GM41
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 13 Sep 2017 13:45

Re: Utiliser plusieurs conditions?

Messagepar zeguedon » 13 Sep 2017 14:59

Bonjour,

Il faut d'abord créer un tableau de correspondances sur une autre feuille par exemple :
TableauDeCorrespondance.png
TableauDeCorrespondance.png (10.43 Kio) Consulté 171 fois

Puis utiliser la fonction RECHERCHEV() :
Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(A1;$Feuille1.$A$1:$B$11;2;0)


A+
Pièces jointes
RECHERCHEV.ods
(10.35 Kio) Téléchargé 11 fois
Comment baliser [Résolu] ?
AOO 4.1.3
LibreOffice 5.2.6.2
Debian (Jessie)
Avatar de l’utilisateur
zeguedon
ManitOOu
ManitOOu
 
Message(s) : 2532
Inscrit le : 02 Juil 2014 18:25
Localisation : Dans les Caraĩbes

Re: Utiliser plusieurs conditions?

Messagepar GM41 » 14 Sep 2017 08:18

zeguedon a écrit:Bonjour,

Il faut d'abord créer un tableau de correspondances sur une autre feuille par exemple :
TableauDeCorrespondance.png

Puis utiliser la fonction RECHERCHEV() :
Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(A1;$Feuille1.$A$1:$B$11;2;0)


A+


ok je vois à peu près la démarche! mais la fonction recherche je ne la maîtrise pas... dans la ligne cela équivaudrait à:

- rechercher la valeur A1 de la feuille 2 dans la feuille 1 colonne A à partir de A1? et lui adjoindre la valeur colonne correspondante en s'arrêtant à B11?
- le "2;0" je ne vois pas du tout ... mais je cherche du coup à droite à gauche... :fou:

en tout cas merci, dans ce fichier c'est exactement ce que je cherche à faire en comprenant le fonctionnement de cette commande :super:
OpenOffice 5.1.6.2 sous Ubuntu
GM41
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 13 Sep 2017 13:45

Re: Utiliser plusieurs conditions?

Messagepar tintin » 14 Sep 2017 08:21

Bonjour,

Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(A1;$Feuille1.$A$1:$B$11;2;0)

Rechercher le contenu de la cellule A1 dans la zone de cellules A1:B11 de la feuille1 et donner la réponse dans la colonne 2 (Les $ indiquent les références absolues des cellules).
Le 0 signifie que la colonne n'est pas triée
La valeur 1 signifierait que la colonne est triée

Voir le tutoriel de gerard24 sur l'Utilisation des Fonctions de recherche
AOO 4.1.3 / MacOS X 10.13.1 High Sierra / RAM 8Go / Time Machine
Java 1.8.0_152/ Firefox / Safari / Thunderbird
Tutoriels du forum pour MacOS
Pensez à sauvegarder régulièrement votre travail avec l'
extension de sauvegarde incrémentale
Avatar de l’utilisateur
tintin
ManitOOu
ManitOOu
 
Message(s) : 4627
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Utiliser plusieurs conditions?

Messagepar GM41 » 14 Sep 2017 09:23

ok merci :) et justement j'avais commencé de lire ce tuto :super:

en tout cas merci à tous d'apporter vos pierres à mon édifice parce que c'est assez complexe de se lancer :wink:
OpenOffice 5.1.6.2 sous Ubuntu
GM41
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 13 Sep 2017 13:45


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 19 invité(s)