[RESUELTO] Problemas con multiplicación

Discute sobre la aplicación de hojas de cálculo

[RESUELTO] Problemas con multiplicación

Notapor benalfe » Sab Jun 17, 2017 12:41 pm

Saludos amigos.

Estoy trabajando en un proyecto con OpenOffice Calc y estoy teniendo un problema con una multiplicación que me saca los resultados cambiados, les explico...

Resulta que se trata de una hoja para calcular descuentos por cantidad de compra y cuando hago la operación de multiplicar el contenido de una celda por otra, el resultado sale incorrecto y no se cual puede ser la razón.

Aquí dejo el archivo para descargarlo y que lo veáis funcionando:
Descargar Ejemplo

La celda D14 tiene el precio con el descuento que se calcula por cantidad comprada y contiene este código
Código: Seleccionar todo   Expandir vistaContraer vista
=E2-(B14*E2)/100

Por otro lado, la celda A14 contiene la cantidad de piezas compradas.

El problema está en el resultado que aparece en la celda E14, la cual tiene como código
Código: Seleccionar todo   Expandir vistaContraer vista
=D14*A14
, en este ejemplo la cantidad vendida son 45 (en A14) y el PVP son 2,24 (en D14), lo que en E14 debería aparecer el resultado de 100,80€ y por alguna razón devuelve 100,98€.

He podido apreciar de que el error está en la celda D14, porque si os fijáis, he hecho la misma operación en la celda E15 con el código
Código: Seleccionar todo   Expandir vistaContraer vista
=A14*G15
, en el que he cambiando la celda D14 por G15 y ahora devuelve el resultado correcto, cabe destacar que la celda G15 no tiene ningún código y sólo contiene el texto 2,24.

¿Alguien me podría explicar por qué pasa esto y devuelve el resultado erróneo?, necesito saber cómo solucionarlo.

Muchas gracias de antemano.
Última edición por mauricio el Dom Jun 18, 2017 3:04 pm, editado 2 veces en total
Razón: Marcar icono de resuelto
OpenOffice V 4.0.0
Windows XP SP3
benalfe
 
Mensajes: 34
Registrado: Mié Sep 18, 2013 6:00 pm

Re: Problemas con multiplicación

Notapor mauricio » Sab Jun 17, 2017 3:44 pm

así sin ver, "casi" te puedo asegurar que es un asunto de redondeo... eso si, puedo asegurar que la hoja de calculo no se equivoca, pero... falta ver...

prueba a usar la función REDONDEO en cada operación que hagas y nos cuentas.

Saludos
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
AOO 4.1 | LibO 5.0 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 5136
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: México, D.F.

Re: Problemas con multiplicación

Notapor benalfe » Sab Jun 17, 2017 5:20 pm

Hola Mauricio y muchas gracias por responder.

Bueno, he probado a redondear pero no he tenido suerte, te muestro lo que he probado.

En la celda D14 he puesto el siguiente código:
Código: Seleccionar todo   Expandir vistaContraer vista
=REDONDEAR(E2-(B14*E2)/100)
y me devuelve 2,00€ (debería devolver 2,24€)

Si en E14 pongo el código
Código: Seleccionar todo   Expandir vistaContraer vista
=REDONDEAR(D14*A14)
me devuelve 101,00 € y debería devolver 100,80€

Si en E14 pongo el código
Código: Seleccionar todo   Expandir vistaContraer vista
=REDONDEAR(D14*A14;2)
me devuelve 100,98 € igual que antes sin redondear.

He comprobado el formato de las celdas D14 y E14 y son de Moneda, la celda A14 es de números, creo que está todo correcto menos el fallo que he cometido y no se donde. :(

¿Alguna otra idea?

Saludos.
OpenOffice V 4.0.0
Windows XP SP3
benalfe
 
Mensajes: 34
Registrado: Mié Sep 18, 2013 6:00 pm

Re: Problemas con multiplicación

Notapor xiseme » Sab Jun 17, 2017 10:33 pm

Si Mauricio dice "casi"... seguramente lo es: 2,244 <> 2,24
No tienes que redondear el resultado total, tienes que redondear el unitario (El PVP unitario aplicado el porcentaje)
Redondea la columna D → =REDONDEAR(E3-(B7*E3)/100;2)
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
xiseme
 
Mensajes: 1824
Registrado: Lun Nov 24, 2008 1:13 pm

Re: Problemas con multiplicación

Notapor benalfe » Dom Jun 18, 2017 9:30 am

Gracias xiseme por la aclaración, la verdad estaba un poco perdido sobre donde aplicar este redondeo pero lo que está claro es que yo solo no lo habría podido solucionar.

La modificación que he hecho es aplicar a la celda D14 el siguiente código
Código: Seleccionar todo   Expandir vistaContraer vista
=REDONDEAR(E2-(B14*E2)/100;2)
y ahora si ha funcionado a la perfección. :bravo:

Muchas gracias por vuestra valiosa ayuda y con esto ya doy el problema por solucionado.

Que paséis un Feliz Domingo.
OpenOffice V 4.0.0
Windows XP SP3
benalfe
 
Mensajes: 34
Registrado: Mié Sep 18, 2013 6:00 pm


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 25 invitados