Búsqueda en una tabla con dos variables

Guías sobre la hoja de cálculos
Reglas del Foro
Este sub-foro no es para hacer preguntas
Aquí encontrará guías básicas sobre cómo utilizar AOO Calc. Para realizar preguntas sobre estas guías, por favor inicie un nuevo tema en el sub-foro apropiado.

También puede consultar la Documentación disponible sobre Apache OpenOffice

Búsqueda en una tabla con dos variables

Notapor PepeOooSevilla » Vie Jun 03, 2016 6:46 pm

>>> Caso:
Tenemos que hallar una tasa (porcentaje), previamente establecida (datos ficticios), que va en función de dos variables: los ingresos y el número de hijos (ver imagen).

>>> Solución:
Nos la da la fórmula =BUSCARV(B13;$B$4:$F$10;1+COINCIDIR(B14;$C$3:$F$3)) del archivo de ejemplo que se adjunta.

¡Atención! Si queremos que la búsqueda sea por datos exactamente iguales (no por tramos) entonces a la función BUSCARV() se le tiene que añadir un cuarto parámetro (opcional) que le indique ese estado. En este caso es el número 0 (cero) o la función FALSO().
Igualmente con la función COINCIDIR(). Aquí sería el tercer parámetro (opcional) al que le tendríamos que poner el valor 0 (cero).

Para más información sobre estas funciones y sus parámetros debemos consultar la Ayuda de Calc.

Como podemos comprobar, la solución a este caso se puede aplicar a otros casos parecidos.

Saludos cordiales.
Adjuntos
BUSQUEDA CON DOS VARIABLES.ods
LibreOffice Calc 5.1.3
(17.26 KiB) 71 veces
Tasa.png
Tasa a aplicar dependiendo de los ingresos y número de hijos
LibreOffice 5.3.7 (estable) en Windows 7 / 10
Por favor, utiliza el Foro para tus consultas, no los mensajes privados
PepeOooSevilla
 
Mensajes: 741
Registrado: Sab Abr 04, 2009 6:10 pm
Ubicación: Sevilla (España)

Re: Búsqueda en una tabla con dos variables

Notapor xiseme » Sab Jun 04, 2016 11:46 am

:super:
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
xiseme
 
Mensajes: 1846
Registrado: Lun Nov 24, 2008 1:13 pm

Re: Búsqueda en una tabla con dos variables

Notapor SLV-es » Mar Jun 21, 2016 11:50 am

:super: :bravo: :bravo: :bravo:
+info en la web "no oficial" dedicada a OpenOffice en Español
AOO 4.1.2 y LibO 4.4.6 en W10 y en Lliurex
No respondo mensajes privados sobre AOO, por favor, utiliza el foro para tus preguntas
Avatar de Usuario
SLV-es
 
Mensajes: 4873
Registrado: Jue Ago 26, 2010 1:25 am
Ubicación: España


Volver a Guías para Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado