Spell checker "red wriggly lines" - beta test fix for AOO

Home made tutorials, by users, for users
Forum rules
No question in this forum please
For any question related to a topic, create a new thread in the relevant section.

Spell checker "red wriggly lines" - beta test fix for AOO

Postby John_Ha » Tue Oct 11, 2016 11:05 am

If you get red wriggly lines under every word you type it is because AOO has "lost contact" with the dictionary and is therefore flagging every word as misspelled.

The following macro has been written by hanya - hanya is a developer - with a view to fixing the problem easily. It is likely that the code will be included with future releases of AOO in which case only Steps 6 onwards will be needed.

A major advantage of using the macro to repair AOO is that all of your settings are kept. If you choose instead to rebuild the profile yourself, you lose all your settings and you have to copy them back from the old profile.

These instructions are based on Windows 7. Windows 8 and Windows 10 should be almost identical. Apple Mac and Linux should be similar.

 Edit: The macro has been developed to work with Apache OpenOffice.

Using the macro with LibreOffice

The macro has not been tested with LibreOffice but doing as below will allow you to back out any changes made by the macro.

1. Copy the User Profile - take a copy of C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user. You may need to make hidden files visible to see it.
2. Follow the instructions in the article.
3. If anything goes wrong, replace the now changed C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user with the one you copied earlier.
 

1. You will first need to make hidden files visible by Start > Control Panel > Folder Options > View > select Show hidden files, folders and drives. In Windows 10, go File Explorer > View (Ribbon tab) > Options ... to open the Folder Options/File Explorer Options window.

2. Use Windows Explorer and go to C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user\Scripts (where xxxxxx is your username) and open the folder. right-click inside the folder > New > Folder ..., and create a new folder called python. Note: you must use all lower case letters for "python" or Writer will not see the file.

 Edit: If you are still using AOO 3.x - you should not be as there are security implications - I think the path is C:\Users\xxxxxx\AppData\Roaming\OpenOffice.org\4\user\Scripts OpenOffice.org 

3. Download the attached config_backend_cleaner.py.zip file and place it on the desktop.

4. Double click config_backend_cleaner.py.zip file to open it > right-click config_backend_cleaner.py > Copy. This takes a copy of the file.

5. Go back to C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user\Scripts\python > right-click inside the folder > Paste. This pastes the file config_backend_cleaner.py into the folder ...\python.

6. Close OpenOffice.

7. If you run the quickstarter, close it as well. [Start > Control Panel > Performance Information and Tools > Advanced Tools > Open Task Manager > Processes > left click on Image name (to sort the processes in alphabetical order). Now right-click each soffice.exe and soffice.bin > click End Process - they will all disappear.]

8. Start OpenOffice

9. Go Tools > Macros > Organize Macros > Python > click the [+] by My Macros > click the [+] by config_backend_cleaner > click on cleanup > click Run

10. Close OpenOffice

11. Start OpenOffice

The problem should be fixed.

In the unlikely event that there was a problem with any of your dictionaries, they may need to be removed and reinstalled by Tools > Extension Manager if required. For more assistance see [Troubleshooting] Spell check in OpenOfficee and [Solved] No dictionary present in OpenOffice.

Why do these spell check errors occur?

See RoryOF's post below which says:

RoryOF wrote:While we cannot say for certain, it appears that this problem may often occur with over-hasty power off of your computer. We recommend using the formal computer shut down process, then waiting a few seconds after the "OK to power off" message before hitting the power switch or snapping a laptop lid shut. Wait for disk activity to finish - information is cached within the write buffers of the hard drives and it takes a few seconds for the drive to decide to write it. If you power off too hastily this information is not written and some or all of the OO housekeeping information is lost.

 Edit: Be advised: over-hasty power off as outlined above may also cause damage or catastrophic loss to your document. The few extra seconds of waiting while disk activity ceases will, even cumulatively, be much less than the time needed to attempt to recover, or, more likely, to rewrite a damaged or lost document. 
Attachments
config_backend_cleaner.py.zip
Python macro to fix spell check problems - unzip to extract the macro
(5.45 KiB) Downloaded 1395 times
Last edited by John_Ha on Mon Jun 11, 2018 1:37 pm, edited 26 times in total.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5838
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Spell checker "red wriggly lines" - beta test fix

Postby ME-NOT-YOU » Mon Jun 19, 2017 12:19 pm

As requested,

I have tried your Macro patch, and it has had the desired results, thank you.

:bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo: :bravo:
Win 7 Ultimate running OpenOffice 4.1
ME-NOT-YOU
 
Posts: 1
Joined: Mon Jun 19, 2017 12:15 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby wildfire77 » Mon Jun 19, 2017 3:44 pm

This saved my spellcheck. Thank you! :super:
Apache OpenOffice 4.1.2 on Windows 10 Home
wildfire77
 
Posts: 1
Joined: Mon Jun 19, 2017 3:42 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby TFKidd » Tue Jun 20, 2017 3:40 pm

I came across this problem all of a sudden and it drives me crazy. I have been trying to fix it even to the point of uninstalling and reinstalling new version. To no luck. I came across this and WALLA it fixed. Thank You SO MUCH. Now I can work without having to :knock: in Annoyance. Thank Again :super:
Apache OpenOffice 4.1.3
Windows 10 64B
TFKidd
 
Posts: 1
Joined: Tue Jun 20, 2017 3:31 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby jeffs12 » Wed Jul 19, 2017 12:53 am

The macro worked - Thanks!
However, the config_backend_cleaner appeared under My Macros rather than OpenOfficeMacros.
AOO 4.1.3 on M$ Windows 7/10
jeffs12
 
Posts: 36
Joined: Wed Mar 19, 2008 9:48 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby John_Ha » Fri Jul 28, 2017 11:35 am

jeffs12 wrote:The macro worked - Thanks!
However, the config_backend_cleaner appeared under My Macros rather than OpenOfficeMacros.

I'm not sure why that happened, but it does not matter as long as you could find and run it.

We hope that the macro will be included with AOO 4.1.4 so users will just be able to access it and run it.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5838
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Spell checker "red wriggly lines" - beta test fix

Postby jeffs12 » Sat Jul 29, 2017 7:29 am

John_Ha - Thanks for the reply.

FYI, another issue I found - a couple of days after I ran the fix I was unable to run database reports created with the Oracle Report Builder extension. I don't know if this was a symptom of the profile crash or running the fix as I had not tried running a report after the crash but before the fix. It took a bit of work to force the extension back in but once I got it back in the reports worked fine.
AOO 4.1.3 on M$ Windows 7/10
jeffs12
 
Posts: 36
Joined: Wed Mar 19, 2008 9:48 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby John_Ha » Mon Jul 31, 2017 10:14 am

I doubt that was caused by the macro.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5838
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Spell checker "red wriggly lines" - beta test fix

Postby W.Goepner » Tue Aug 01, 2017 4:02 am

OMG! I missed the show hidden files, thanks for the patch!
Open Office 4.1.3
Win 10
W.Goepner
 
Posts: 2
Joined: Sun Jul 30, 2017 10:59 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby 1Parcham » Fri Aug 04, 2017 8:10 pm

Wow, this actually fixed my problem!! Thanks so much!! I was about to give up after going through all the steps in the troubleshooting guide! I use Open Office every day, some of my documents are over 400 pages and then, all of a sudden, every line was underlined with the red squiggly line saying it was misspelled. I was about to panic! But, thanks to this fix, problem solved! Yeah!
Open Office 4.1.3
Windows 10 Home
1Parcham
 
Posts: 2
Joined: Fri Aug 04, 2017 8:06 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby RoryOF » Fri Aug 04, 2017 10:47 pm

While we cannot say for certain, it appears that this problem may often occur with over-hasty power off of your computer. We recommend using the formal computer shut down process, then waiting a few seconds after the "OK to power off" message before hitting the power switch or snapping a laptop lid shut. Wait for disk activity to finish - information is cached within the write buffers of the hard drives and it takes a few seconds for the drive to decide to write it. If you power off too hastily this information is not written and some or all of the OO housekeeping information is lost.

 Edit: Be advised: over-hasty power off as outlined above may also cause damage or catastrophic loss to your document. The few extra seconds of waiting while disk activity ceases will, even cumulatively, be much less than the time needed to attempt to recover, or, more likely, to rewrite a damaged or lost document. 
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27472
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell checker "red wriggly lines" - beta test fix

Postby 1Parcham » Sat Aug 05, 2017 1:16 am

That is very possible. I know last night I shut down Open Office and immediately shut down my computer. I was in a rush and shut my laptop before it finished powering off which I don't usually do. Perhaps that did cause the problem.
Open Office 4.1.3
Windows 10 Home
1Parcham
 
Posts: 2
Joined: Fri Aug 04, 2017 8:06 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby fessbonneville » Sat Aug 05, 2017 4:03 pm

Worked for me. Thanks you very much!
:bravo:
open Office 4.1.1 on Windows 10
fessbonneville
 
Posts: 3
Joined: Wed Aug 19, 2015 8:34 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby John_Ha » Sat Aug 05, 2017 4:25 pm

1Parcham wrote:That is very possible. I know last night I shut down Open Office and immediately shut down my computer. I was in a rush and shut my laptop before it finished powering off which I don't usually do. Perhaps that did cause the problem.

I am trying to debug problems like this and I am hoping you can help me.

Can you please tell me exactly what your laptop does when you close the lid. Go Start > Settings > Power and Sleep. left-click the Additional Power settings link (bottom right). left-click the Choose what closing the lid does link (top left).

Question 1: What does it say for When I close the lid on battery, and When I close the lid plugged in? See image below.

Question 2: Were you running on battery? or plugged in? when you closed the lid.

Question 3: Can you please describe exactly what steps you took in detail. Something like "I was running plugged in. I clicked Save to save the document I was editing. I closed Writer by clicking the X at top right. I shut the lid ... or I pressed the OFF button and then shut the lid ..." or whatever it was that you actually did

Many thanks

 Edit: 1parcham send me a detailed description of what was done - many thanks. 
Attachments
Clipboard01.png
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5838
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Spell checker "red wriggly lines" - beta test fix

Postby Jigbusteruk » Sat Sep 09, 2017 12:11 pm

The script in "python" solved the problem for me - thanks!
The file path wasn't quite what you gave. Instead of "Folder Options" I had to use "File Explorer Options" - perhaps a quirk of my version of Windows 10?
Tony
OpenOffice 4.1.3 on Windows 10
Jigbusteruk
 
Posts: 1
Joined: Sat Sep 09, 2017 12:08 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby Bill » Sat Sep 09, 2017 5:50 pm

Jigbusteruk wrote:The file path wasn't quite what you gave. Instead of "Folder Options" I had to use "File Explorer Options" - perhaps a quirk of my version of Windows 10?
Tony


"Start > Control Panel > Folder Options > View" is a sequence of mouse clicks, not a file path. The Control Panel is being phased out in Windows 10 and the Control Panel has been removed from the Start menu, so the click sequence isn't valid in Windows 10. However, clicking Start and searching for "folder options" finds "File Explorer Options" in what's left of the Control Panel, but the easiest way to change the view options is to click the View tab on the Ribbon in File Explorer.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6898
Joined: Sat Nov 24, 2007 6:48 am

Re: Spell checker "red wriggly lines" - beta test fix

Postby pastor238 » Sat Nov 04, 2017 11:36 pm

I did the steps above which took care of the red lines, but now my spell check does not work at all. I have checked all the languages and the are all set to English USA. What can I do to fix the problem of the spell check not working at all now?
OpenOffice 4.1.3 on Windows 10 Home
pastor238
 
Posts: 1
Joined: Sun Apr 23, 2017 12:31 am

Re: Spell checker "red wriggly lines" - beta test fix

Postby Ruthla » Mon Nov 06, 2017 5:34 pm

I'm lost. I went through most of the steps and it APPEARS that everything is as it should be- English (USA) is properly set up in all the places. I did the setup thing for not hiding "hidden files.

Then I got lost at this step:

1 Navigate to C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user\Scripts (where xxxxxx is your username) and open the folder. right-click inside the folder > New > Folder ..., and create a new folder called python. Note: you must use all lower case letters for "python" or Writer will not see the file.

Navigate HOW exactly? From Google Chrome? From inside of OO? From my start menu? Nothing inside the start menu looks anything like that. And I don't think I even HAVE a username for offline files on my computer?
openoffice 4.1.1 on windows 7 home premium
Ruthla
 
Posts: 4
Joined: Thu Jul 30, 2015 10:17 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby FJCC » Mon Nov 06, 2017 7:30 pm

An easier version of that instruction ( I hope):
Open any file folder on your computer (e.g. My Documents) and in the address bar near the top type
%appdata%\openoffice\4
That should take you to a folder that contains a folder named user. Double click on the user folder to open it and then double click on the Scripts folder to enter that. You can then proceed with the instruction "right-click inside the folder > New > Folder ..., and create a new folder called python."
AOO 3.4 or 4.1 on MS Windows XP ( before 2013-08-03) or Windows 7
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 6803
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Spell checker "red wriggly lines" - beta test fix

Postby cemkono » Tue Nov 07, 2017 6:04 am

Normally, I write using a pen but for a website total guide article, I need to write digitally to publish a new blog post for my writing job. But, I was facing grammar error problem. Thus, a good grammar checker was necessary. I set up windows recently and installed openoffice. But, still I was facing this spell checking problem. Then, Followed those 10 steps and problem are solved instantly.
Last edited by cemkono on Wed Dec 06, 2017 4:20 am, edited 4 times in total.
OpenOffice 4.1 on Windows 10
cemkono
 
Posts: 1
Joined: Tue Nov 07, 2017 5:54 am

Re: Spell checker "red wriggly lines" - beta test fix

Postby John_Ha » Sat Nov 11, 2017 1:27 am

Ruthla wrote:I'm lost ... Navigate HOW exactly?

I am sorry you were confused. I have changed the instructions to:

1 Use Windows Explorer and go to C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user\Scripts ...
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5838
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Spell checker "red wriggly lines" - beta test fix

Postby Lesley_Vos » Tue Nov 14, 2017 3:27 pm

As a writer, I don't like spell checkers much -- they miss so many typos or, vice versa, underline words with no typos at all -- but these instructions are useful by all means! Makes the work with spell checkers less frustrating :D Thanks!

:bravo: :bravo: :bravo:
OpenOffice 4.1.4 on Windows 8
User avatar
Lesley_Vos
 
Posts: 12
Joined: Wed Oct 25, 2017 11:32 am
Location: Chicago, IL

Re: Spell checker "red wriggly lines" - beta test fix

Postby RoryOF » Tue Nov 14, 2017 3:50 pm

I don't find the Spellchecker misses many typos; for each work I build ~ as I write - a user dictionary of the names and places, sometimes also of the terms and vocabulary used. The effect of this is to leave very few erroneous spelling indications.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27472
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell checker "red wriggly lines" - beta test fix

Postby Paj » Wed Dec 06, 2017 12:26 am

Dear John Ha,
I'm buying you a virtual beer and as many real ones as you can quaff if I ever run into the actual you. Thank you so much for that macro fix. That irritating, ridiculous, recurring Spell-Check bug is the major reason I put off upgrading as long as possible.

Thanks again.

Sincerely,
Paj
8^)
OpenOffice 4.1.1 on Vista
Paj
 
Posts: 4
Joined: Sun Oct 12, 2014 1:34 am

Re: Spell checker "red wriggly lines" - beta test fix

Postby John_Ha » Wed Dec 06, 2017 4:12 pm

While one should never shoot the messenger, one shouldn't praise him or her either. hanya from development wrote the macro and deserves the praise - I merely placed it here.

Remember that if it happens again you just need to navigate to the macro and run it.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5838
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Spell checker "red wriggly lines" - beta test fix

Postby Paj » Thu Dec 07, 2017 3:50 am

John_Ha wrote:While one should never shoot the messenger, one shouldn't praise him or her either. hanya from development wrote the macro and deserves the praise - I merely placed it here.

Remember that if it happens again you just need to navigate to the macro and run it.


I don't confuse thanks with praise but, nonetheless, thanks to both of you.

Paj
8^)
OpenOffice 4.1.1 on Vista
Paj
 
Posts: 4
Joined: Sun Oct 12, 2014 1:34 am

Re: Spell checker "red wriggly lines" - beta test fix

Postby nevermundahne » Wed Dec 20, 2017 8:45 pm

I followed the instructions, ran the script, no problems there. Afterwards, spellchecker stopped working altogether. No more wavy red lines at all. Spellchecker is turned on, all languages are set to English, and it doesn't register any misspelled words.

I also tried installing an English dictionary update and it won't install, and the previously installed one is gone. It says the 'dict-en-20170901.oxt' does not exist'

On November 07 2017, pastor238 asked the same questions, and no one replied, unless I am blind and missed it. Please advice, thanks!
Last edited by nevermundahne on Wed Dec 20, 2017 8:53 pm, edited 1 time in total.
Windows 10, 64 bit
Open Office 4.1.4
nevermundahne
 
Posts: 3
Joined: Wed Dec 20, 2017 8:35 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby RoryOF » Wed Dec 20, 2017 8:49 pm

The quick, almost certain, solution is to rename your OO user profile.

Shutdown OpenOffice. Open any folder and enter
%appdata%\openoffice\4
in the address bar at the top. That should take you to a folder that contains a folder called user. Rename that folder user_old and restart OpenOffice. Is the problem fixed?
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27472
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell checker "red wriggly lines" - beta test fix

Postby nevermundahne » Wed Dec 20, 2017 8:59 pm

Thanks, I've done that before, I was hoping that this would be a simpler fix. I get tired of doing this when it happens. Every once in while, it randomly does the 'Welcome to...' thing, and I have to reapply all of my settings, But it does work.
Windows 10, 64 bit
Open Office 4.1.4
nevermundahne
 
Posts: 3
Joined: Wed Dec 20, 2017 8:35 pm

Re: Spell checker "red wriggly lines" - beta test fix

Postby RoryOF » Wed Dec 20, 2017 9:12 pm

It is possible that you are powering down your computer before the internal housekeeping is finished. Use the formal computer power-down procedure and wait for about ten seconds after all disk activity is finished before disconnecting the power or snapping a laptop's lid shut.

 Edit: It is possible also if you download using Internet Explorer that this will silently rename the dictionary from type .oxt to type .zip; one should, outside of OO, rename it back to type .oxt; double clicking on this will then install it. 
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27472
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Next

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 1 guest