Stop automatic insertion of new lines in footnotes

Discuss the word processor

Stop automatic insertion of new lines in footnotes

Postby stnthn » Tue Sep 12, 2017 8:12 pm

I have a 380 page document split into different chapters. Every time I reopen the file, the first footnote of every chapter has a number of new lines inserted before the text, anything from say 5 to 25 new blank lines. I delete these each time but the problem reoccurs on next file opening. It's only the first footnote of each chapter that is affected. Maybe worth saying that each chapter was copied into the 380 page file from separate chapter files. Anyone know how to fix this?
Last edited by Hagar Delest on Thu Sep 14, 2017 8:51 pm, edited 2 times in total.
Open Office Writer 4.1.3, Mac OS (El Capitan).
stnthn
 
Posts: 5
Joined: Tue Sep 12, 2017 8:08 pm

Re: Trying to stop automatic insertion of new lines in footn

Postby RoryOF » Tue Sep 12, 2017 8:29 pm

In which format are you Saving the file(s)?
Apache OpenOffice 4.1.3 on Xubuntu 16.04 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 24924
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Trying to stop automatic insertion of new lines in footn

Postby stnthn » Tue Sep 12, 2017 8:33 pm

RoryOF wrote:In which format are you Saving the file(s)?


.doc
Open Office Writer 4.1.3, Mac OS (El Capitan).
stnthn
 
Posts: 5
Joined: Tue Sep 12, 2017 8:08 pm

Re: Trying to stop automatic insertion of new lines in footn

Postby RoryOF » Tue Sep 12, 2017 8:35 pm

Try .odt.
Apache OpenOffice 4.1.3 on Xubuntu 16.04 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 24924
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Trying to stop automatic insertion of new lines in footn

Postby stnthn » Tue Sep 12, 2017 8:41 pm

RoryOF wrote:Try .odt.


Could there be any other way to fix the issue? I will need to send the file as a .doc to a third party at the end of the project. Never had this issue before.
Open Office Writer 4.1.3, Mac OS (El Capitan).
stnthn
 
Posts: 5
Joined: Tue Sep 12, 2017 8:08 pm

Re: Trying to stop automatic insertion of new lines in footn

Postby jrkrideau » Tue Sep 12, 2017 9:59 pm

stnthn wrote:
RoryOF wrote:Try .odt.


Could there be any other way to fix the issue? I will need to send the file as a .doc to a third party at the end of the project. Never had this issue before.


Possibly but try saving in .odt and see if that solves your problem. At the moment we cannot tell if it is an AOO or MS problem.


Every time you open a .doc file in AOO or save a .odt file in .doc format you are translating the document and while the translators are very good they are not perfect and minor errors can accumulate which is why the advice here is to always save in .odt format and only export to a foreign format such as .doc when and if you need to send a copy to one of the benighted.
LibreOffice 5.1.4.2 Ubuntu 17.04 "Zesty Zapus"
jrkrideau
Volunteer
 
Posts: 3327
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Trying to stop automatic insertion of new lines in footn

Postby Zizi64 » Tue Sep 12, 2017 10:06 pm

Could there be any other way to fix the issue?


I think, there is not... Because the different fileformats have not 100% compatibility. You always will lost some formatting properties at the conversions. Always use the International Standard ODF fileformats. Or send the file in PDF fileformat - if it not needed to edit it.

There is many free reader software for the PDF fileformat, and everybody can install a PDF reader software.
And there are free reader and EDITOR software (AOO and LO) for the ODF fileformat. Why can not everybody install a free office suite?????
Tibor Kovacs, Hungary; LibreOffice4.4.7 on Win7x64Prof.
And the portable versions: LO3.3.0-LO5.3.4 and AOO4.1.3
Please, edit the topic's initial post, and add the word "[Solved]" at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 5744
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Trying to stop automatic insertion of new lines in footn

Postby John_Ha » Wed Sep 13, 2017 12:06 pm

See [Tutorial] Differences between Writer and MS Word files for why the file probably looks different as a .doc. Have you turned off this warning message?

Clipboard01.png
Warning message that content may be lost when saving as a .doc file
Clipboard01.png (66.74 KiB) Viewed 184 times

Note that MS Word can read .odt files so send a .odt file and, if MS Word messes up the file, get the user to complain to Microsoft because it is then guaranteed to be Microsoft which is corrupting the layout (as long as the fonts are installed on that PC).

If you absolutely must send a .doc, and not a .odt or .pdf (never use .rtf), protest vigorously. If you have to, then you must open the .doc file and correct any format changes before sending it. If you now re-save this .doc as a .odt file there is a chance you might get new format changes.

Be sure to check that all fonts you use are available on all other PCs likely to open the .odt or .doc or there will be layout changes. PDF files embed the fonts so display correctly even if the font is not available on the other PCs. Always remember that the font showing in the Writer font drop-down selection box is the font the document is asking for and this may NOT be the font being used to create the display because, if the font being asked for is not installed on the PC, Windows (or other operating system) will silently substitute a different font which is available. This almost always causes layout problems.

The TestFonts add-on is invaluable for finding missing fonts which the document is asking for, but which are not installed on the PC.

You can see which fonts are installed on the PC by Start > Control Panel > Fonts or by clicking C:\Windows\Fonts.

Upload a small .odt file and the .doc file created from it which shows the problem so someone can look at it. Use the Upload attachment tab below where you type - 128 kB max here or use a file share site.
AOO 4.1.3, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4336
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Trying to stop automatic insertion of new lines in footn

Postby stnthn » Thu Sep 14, 2017 9:47 am

Thanks for your replies. I will try the .odt option.

I have attached here a new file I created in .odt and .doc versions. I'm not getting the same error replicated in this however (either in OO Writer or MS Word), whereas with my large file I'm getting the error in both. Seems strange that I have used OO Writer for years, always saving in .doc extension, and never had this problem until this file. The file is completely created by me, not from anyone else.

UPDATE: from a quick fiddle around, using the .odt option seems to eliminate the problem.
Attachments
openofficetest.odt
(12.1 KiB) Downloaded 6 times
openofficetest.doc
(22.5 KiB) Downloaded 3 times
Open Office Writer 4.1.3, Mac OS (El Capitan).
stnthn
 
Posts: 5
Joined: Tue Sep 12, 2017 8:08 pm

Re: Trying to stop automatic insertion of new lines in footn

Postby John_Ha » Thu Sep 14, 2017 1:10 pm

stnthn wrote:Every time I reopen the file, the first footnote of every chapter has a number of new lines inserted before the text, anything from say 5 to 25 new blank lines.

Are these extra lines (empty paragraphs)? Or is it extra white space which should not be there?

Clipboard01.png
Clipboard01.png (6.54 KiB) Viewed 146 times

See [Solved] AOO stops responding when opening this one document
I am now fairly certain it is a pagination and/or layout problem.

There are often situations which are potentially unstable. For example, consider what happens if footnote xyz position is on the last line of the text before the footnotes start, and footnote xyz itself is the last footnote on the page. There are many such instances.

Say there is now a text spill on that page during page layout. The spill pulls the last line of text with the footnote position onto the next page > which pulls the footnote itself onto the next page > which frees up empty space on the previous page > which allows the line of text to be pulled back > which brings back the footnote pointer in that line > which brings back the footnote itself > but there isn't enough space for it > so the last line of the text with the footnote pointer gets spilled ... and we get back to where we started. The loop is endless but AOO pulls out of the loop after a set time and the layout is as it was when AOO pulled out.

This is why the page count is so variable. .

Note also how the table extends over multiple pages. Note also how, when the page count is higher than it should be, that there are gaps below the table rows on many pages, and white space to the end of that page. This is why the page count is high. If I then click PREVIEW, I get a message (bottom left?) saying Re-paginating, and the page numbers drop and the preview does not have any gaps. When I then go back to normal, the gaps are gone. So PREVIEW seems to force re-pagination on both Preview and normal view.
AOO 4.1.3, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4336
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Trying to stop automatic insertion of new lines in footn

Postby stnthn » Thu Sep 14, 2017 8:31 pm

John_Ha wrote:
stnthn wrote:Every time I reopen the file, the first footnote of every chapter has a number of new lines inserted before the text, anything from say 5 to 25 new blank lines.

Are these extra lines (empty paragraphs)? Or is it extra white space which should not be there?


Extra lines/paragraphs.

The link you give is interesting though it should be for extra white space I think?
Open Office Writer 4.1.3, Mac OS (El Capitan).
stnthn
 
Posts: 5
Joined: Tue Sep 12, 2017 8:08 pm

Re: Stop automatic insertion of new lines in footnotes

Postby John_Ha » Fri Sep 15, 2017 8:21 pm

The link was about white space.

I have sent you a private message with my email id. If you send me the file I will look at it.
AOO 4.1.3, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4336
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Stop automatic insertion of new lines in footnotes

Postby John_Ha » Mon Sep 18, 2017 10:59 am

stnthn sent me his file.

Everything was normal. What seemed to be happening was that, when entering his footnote text, he had been adding new paragraphs. I just deleted them. I then added some new footnotes by Insert > Footnote ..., and they picked up the Footnote Style without any extra lines.

He had a suitable style for footnotes where the text indents by a short distance but, at some stage, it seems he had directly formatted some of the footnotes and changed this indent.

If this solves the problem, please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject.
Attachments
Clipboard01.png
AOO 4.1.3, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4336
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Writer

Who is online

Users browsing this forum: No registered users and 29 guests